ServiceNow Securlet failed to get authorization token
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ServiceNow Securlet failed to get authorization token

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Article ID: 172529

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Updated On:

Products

CASB Security Standard CASB Security Premium CASB Security Advanced CASB Audit CASB Gateway CASB Gateway Advanced

Issue/Introduction

Error when activating the ServiceNow Securlet.

Failed to get authorization token from Servicenow. Please contact the Elastica support team.

Cause

Network communications blocked by proxy/firewall on specific IP whitelisting and the user was unable to communicate to the ServiceNow site and authenticate.

Resolution

Remove IP addresses restrictions to communicate with ServiceNow.

  • IP restrictions are on the ServiceNow side. CloudSOC is unable to present any IP ranges that match the IP addresses allowed in ServiceNow for external sites
  • The entire URL parameter in Elastica is not needed. Example: sampledev instead of sampledev.service-now.com when activating as the header/tail are already in place per the documentation.