Workflow SMP Environment Publishing Error After Workflow Upgrade
search cancel

Workflow SMP Environment Publishing Error After Workflow Upgrade

book

Article ID: 172526

calendar_today

Updated On:

Products

Workflow Solution

Issue/Introduction

After upgrading to a more recent version of Workflow Solution, publishing Workflows to a managed SMP environment is no longer working.  Publishing to local environments works as expected

On-screen: 

Publishing to 'Local SMP' (Managed Environment): 
Server '######': Failure, Reason: Check Workflow Server logs of the target deployment server for the reason
Local SMP: Failure, Reason: Check Workflow Server logs of the target deployment server for the reason

The Workflow ProcessManager logs show:
Application Name : LBUtil.exe
> Process ID : 30036
> Date :8/24/2018 9:20:41 AM
> Log Level :Error
> Log Category :LogicBase.ToolCLI.Actions.DeployProject
> Machine Name : ##########
> Message :
> Error deploying project
> System.ServiceModel.FaultException: Access is denied
>
> Server stack trace:
> at System.ServiceModel.Channels.ServiceChannel.HandleReply
> (ProxyOperationRuntime operation, ProxyRpc& rpc)
> at System.ServiceModel.Channels.ServiceChannel.Call(String action, 
> Boolean oneway, ProxyOperationRuntime operation, Object[] ins, 
> Object[] outs, TimeSpan timeout)
> at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService
> (IMethodCallMessage methodCall, ProxyOperationRuntime operation)
> at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage
> message)
>
> Exception rethrown at [0]:
> at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage
> (IMessage reqMsg, IMessage retMsg)
> at 
> System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&
> msgData, Int32 type)
> at 
> Symantec.Workflow.Deployment.IDeploymentService.DeployWASApplication
> (String appName, String appPoolId, Byte[] package, 
> ApplicationProperty[]
> properties)
> at
>
LogicBase.ToolCLI.Actions.DeployProject.LogicBase.ToolCLI.FileAction.Execute

>
> (Argument[] args, TextWriter output)
>
> -------------------------
>
> Application Name : LogicBase.ServerExtensions.exe Process ID : 26796 
> Date :8/24/2018 9:20:41 AM Log Level :Error Log Category 
> :SWFSVR-DeploymentService Machine Name : ####### Message :
> Access was denied to NT AUTHORITY\SYSTEM
>
> ---------------------------
>
> Application Name : LogicBase.ServerExtensions.exe Process ID : 26796 
> Date :8/24/2018 9:20:41 AM Log Level :Error Log Category 
> :SWFSVR-DeploymentService Machine Name : ####### Message :
> Failed to deploy WAS application DeleteRetrofitComputerWF
> System.UnauthorizedAccessException: SMP authorization failed. 
> Enterprise Management cannot publish directly to an unmanaged server. 
> Please contact administrator.
> at LogicBase.ServerExtensions.Core.DeploymentService.CheckWASAccess
> (WASAccess access, Boolean fromWAS)
> at
>
LogicBase.ServerExtensions.Core.DeploymentService.Symantec.Workflow.Deployment
.IDeploymentService.DeployWASApplication

>
> (String appName, String appPoolId, Byte[] package, 
> ApplicationProperty[]
> properties)

Environment

Workflow 8.1 Ru5 - With a SMP Managed environment and Repository.

Cause

None - Working as Designed.

Resolution

Publishing to servers that are Managed by the SMP is not permitted.  However, on the SMP, you can connect to the Server, and make it temporarily unmanaged, publish to it, and then make it managed.  To do this:

  1.  Go to the SMP
  2. Click on Workflow Enterprise Management.
  3.  Click on the Managed Environment Server
  4. Click Edit Environment
  5. Uncheck the "Is Managed" box
  6. Click Save
  7. Now you can Publish to the Server
  8. Reset it to "Is Managed" by following the steps and rechecking the box.