Filters with a large amount of excluded filters defined are slow to open and cause policies using them to be slow too
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Filters with a large amount of excluded filters defined are slow to open and cause policies using them to be slow too

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Article ID: 172502

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Updated On:

Products

IT Management Suite

Issue/Introduction

Filters with large amounts of excluded filters defined are slow to open and can cause policies using them to be slow as well.

This can be seen when opening a Task, Managed Delivery, Agent Plugin, etc.

Environment

ITMS 8.x

Cause

This is working as designed as the product is designed to resolve targets before loading the items that it uses.

Resolution

There are two options to help minimize the slowness:

Option One:

This is a simpler approach, however, it should be noted that this will also change the default behavior.  After changing this setting the targets will only update when the "Delta Resource Membership Update" runs, and this is found under SMP Console>Settings>Notification Server>Resource Membership Update.  Changing this means that when a policy, task, etc. is opened the targeted resource list is only as accurate as the last membership update.

SMP 8.5 and later:

    1. Go to Settings> Notification Server> Core Settings
    2. Search for "SkipUpdateInvalidTargetsInTargetView" coresetting
    3. Click the Edit icon and change the value to "True"

Option Two:

The query below can be used to see filters that have multiple exclusions defined.  These can then be altered to be a SQL filter or other means to limit the number of exclusions being used:

select c.Name, count (distinct cec.SubCollectionGuid), c.Guid
from CollectionExcludeCollection cec
join vCollection c on c.Guid = cec.CollectionGuid
where c.Attributes = 0
group by c.Name, c.Guid
having count (distinct cec.SubCollectionGuid) > 5
order by count (distinct cec.SubCollectionGuid) desc