Filters with a large amount of excluded filters defined are slow to open and cause policies using them to be slow too

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Article ID: 172502

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Updated On:

Products

IT Management Suite

Issue/Introduction

Filters with a large amount of excluded filters defined are slow to open and cause policies using them to be slow as well.

This can be seen when opening a Task, Managed Delivery, Agent Plugin etc.

Cause

This is working as designed as the product is designed to resolve targets before loading the item that uses it.

Environment

ITMS 8.x

Resolution

There are two options:

Option One: This is the simpler approach, however, it should be noted that this also changes the default behavior.  After changing this setting targets will only update when the "Delta Resource Membership Update" (under SMP Console>Settings>Notification Server>Resource Membership Update)  runs.  Meaning that when a policy, task etc is opened the targeted resource list is only as accurate as the last membership update.

  1. SMP 8.5:
    1. Go to Settings> Notification Server> Core Settings
    2. Search for "SkipUpdateInvalidTargetsInTargetView" 
    3. Click the Edit icon and change the value to "True"
  2. SMP 8.0 POST-HF6 and later
    1. Go to C:\ProgramData\Symantec\SMP\Settings and open the file CoreSettings.config
    2. Search for "SkipUpdateInvalidTargetsInTargetView" 
    3. Change the value from "false" to "True"
    4. Save and close

 

Option Two:

The query below can be used to see filters that have multiple exclusions defined.  These can then be altered to be an SQL filter or other means to limit the number of exclusions being used.

select c.Name, count (distinct cec.SubCollectionGuid), c.Guid
from CollectionExcludeCollection cec
join vCollection c on c.Guid = cec.CollectionGuid
where c.Attributes = 0
group by c.Name, c.Guid
having count (distinct cec.SubCollectionGuid) > 5
order by count (distinct cec.SubCollectionGuid) desc