Patch policies are not received on expected computer(s). When reviewing agent, multiple errors are seen, including, "Could not get Software Update Configuration policy"
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Patch policies are not received on expected computer(s). When reviewing agent, multiple errors are seen, including, "Could not get Software Update Configuration policy"

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Article ID: 172474

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Updated On:

Products

Patch Management Solution Client Management Suite IT Management Suite

Issue/Introduction

Patch policies are not received on the expected computer(s). When reviewing agent, multiple errors are seen, including, "Could not get Software Update Configuration policy"

Could not get Software Update Configuration policy
-----------------------------------------------------------------------------------------------------
Date: 8/24/2021 9:19:39 AM, Tick Count: 129320367 (1.11:55:20.3670000), Size: 309 B
Process: AeXAgentUIHost.exe (6820), Thread ID: 9204, Module: PatchMgmtAgentsUI.dll
Priority: 1, Source: Software Update Agent UI

 

The following three messages would occur together:

<event date='09/15/2018 01:14:25.8140000 +01:00' severity='1' hostName=’<hostname>' source='Software Update Agent UI' module='PatchMgmtAgentsUI.dll' process='AeXAgentUIHost.exe' pid='364' thread='3084' tickCount='275690879' >

  <![CDATA[Could not get Software Update Configuration policy]]>

</event>

<event date='09/15/2018 01:14:25.8300000 +01:00' severity='1' hostName='<hostname>' source='Software Update Agent UI' module='PatchMgmtAgentsUI.dll' process='AeXAgentUIHost.exe' pid='364' thread='3084' tickCount='275690894' >

  <![CDATA[Failed to get SoftwareUpdateAgent from Symantec Management Agent. Please check that the Software Update Agent policy is enabled]]>

</event>

<event date='09/15/2018 01:14:25.8300000 +01:00' severity='1' hostName='<hostname>' source='Software Update Agent UI' module='PatchMgmtAgentsUI.dll' process='AeXAgentUIHost.exe' pid='364' thread='3084' tickCount='275690894' >

  <![CDATA[Empty Schedule Text]]>

 

When looking under the "Software Updates" tab on the Symantec Management Agent UI, there is no a schedule on it.

Environment

Altiris Patch Management Solution 8.x

Cause


The computers in this situation were not targeted by a clone of the Default Software Update Plug-in policy, and/or the Default policy was not enabled.

Note: When creating copies of the a Software Update Plug-in policy, always clone the Default Software Update Plug-in policy to avoid later corruption issues. 

The default and any cloned copies are located in Settings > All Settings > Agents/Plug-ins > Software > Patch Management > Windows.
Cloned copies are useful for targeting unique groups, such as servers and workstations that have different requirements for the scheduling of patch installations and for needed restarts. These clones are targeted using the Applied to section, and the Default Software Update Plug-in Policy applies to all computers that are not in a clone, and this happens automatically. In this case, the Default was turned off (disabled), and the targets in the two cloned policies were not present.

Resolution

Ensure the targets in the Applied to section of cloned Default Software Update Plug-in policies contain all applicable computers. If you choose to disable the Default policy, any computers that are not in a cloned policy will not perform patching. As an alternative, you can set up the Default to an acceptable schedule, or you can set the start data far into the future so that all computers with the Software Update Plug-in will fall into a policy while awaiting assignments that match your targets used in other policies.