New machines are not getting initial configuration. Agent registration status is set to 'Pending'
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New machines are not getting initial configuration. Agent registration status is set to 'Pending'

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Article ID: 172464

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer has new machines that are not getting their agent configuration. These are machines that were recently imaged. 
When the client machine requested its configuration, the following error occurred:

Failed to find the key for server 'HTTP://MySMP01.yourdomain.org/Altiris/NS/Agent/CreateResource.aspx'
 

Entry 1:

Failed to find the key for server 'HTTP://MySMP01.yourdomain.org/Altiris/NS/Agent/CreateResource.aspx'
-----------------------------------------------------------------------------------------------------
Date: 9/12/2018 2:52:01 PM, Tick Count: 13549170 (03:45:49.1700000), Size: 331 B
Process: AeXNSAgent.exe (4568), Thread ID: 4596, Module: AeXNSAgent.exe
Priority: 1, Source: ConfigServer

Entry 2:

Registration request was queued for approval: url=HTTP://MySMP01.yourdomain.org/Altiris/NS/Agent/CreateResource.aspx
-----------------------------------------------------------------------------------------------------
Date: 9/12/2018 2:52:01 PM, Tick Count: 13549170 (03:45:49.1700000), Size: 345 B
Process: AeXNSAgent.exe (4568), Thread ID: 4596, Module: AeXNSAgent.exe
Priority: 4, Source: ConfigServer

Entry 3:

Agent registration status is set to 'Pending'
-----------------------------------------------------------------------------------------------------
Date: 9/12/2018 2:52:01 PM, Tick Count: 13549186 (03:45:49.1860000), Size: 274 B
Process: AeXNSAgent.exe (4568), Thread ID: 4596, Module: AeXNSAgent.exe
Priority: 4, Source: ConfigServer

Entry 4:

Configure Server Mode: Failed to obtain the machine resource GUID, error: Unspecified error (0x80004005)
-----------------------------------------------------------------------------------------------------
Date: 9/12/2018 2:52:01 PM, Tick Count: 13549186 (03:45:49.1860000), Size: 333 B
Process: AeXNSAgent.exe (4568), Thread ID: 4596, Module: AeXNSAgent.exe
Priority: 2, Source: ConfigServer

Environment

ITMS 8.x

Cause

The "Agent Registration Policy - Allow" was disabled.

The Agent logs indicated that "Agent registration status is set to 'Pending'", which means it is waiting for approval to be registered based on the rules assigned under the "Agent Registration Policy - Allow" policy.

Resolution

Enable the "Agent Registration Policy - Allow" policy:

  • Go to the SMP Console, under Settings>Agents/Plug-ins>Symantec Management Agent>Registration Policies
  • Make sure the "Agent Registration Policy - Allow" policy is turned on and has the proper rule to allow those new machines.