Office 365 patches are failing on a significant percentage of targeted clients with an exit code of 1603
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Office 365 patches are failing on a significant percentage of targeted clients with an exit code of 1603

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Article ID: 172403

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Office 365 patches are failing on a significant percentage of targeted clients with an exit code of 1603. The environment is operating under low or controlled bandwidth constraints including bandwidth throttling.

Failed to apply software update [MS18-xx-O365-SEMI-ANNUAL]:Office365-xx.x.xxxx.xxxx-Semi-Annual.cab

 

 

Environment

Patch Management Solution 7.6 post HF7 point fix, 8.0 HF6, 8.1, and 8.5

Cause

The environment is operating under low or controlled bandwidth constraints including bandwidth throttling.

 

Office 365 patches operate differently than other patch or software deliveries, as Office 365 files do not download to the client. They are streamed from an applicable package server. There is a 60 second default time-out that is triggering based on bandwidth constraints in the environment.

Resolution

The following registry entry was tested with bandwidth throttling set to 100kb/s. The decimal value of 600000 is in milliseconds, which equals a 10-minute time-out value.

To test, create a CMD script task (Manage > Jobs and Tasks > right –click any folder and select New > Task. Leave the default Script Type to Command Script. Click on the Advanced button and configure the Show Output section as desired – in production Hidden is recommended.

Paste in the following as the script:

REG ADD "HKEY_USERS\.DEFAULT\Software\Microsoft\Office\16.0\Common\Internet" /V "documentsynctimeout" /t REG_DWORD /d 600000 /f