Getting "Serial Number Has Unexpectedly Changed" message when connecting to SG from Management Center
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Getting "Serial Number Has Unexpectedly Changed" message when connecting to SG from Management Center

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Article ID: 172402

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Updated On:

Products

Secure Web Gateway Virtual Appliance

Issue/Introduction

When a SGVA has been upgraded from 6.7.3.x to 6.7.4.x, Management Center (MC) running versions 1.11.x and later reports that a serial number has changed to a 16-digit hex value (Appliance Identifier/primary MAC address of SGVA unit).
 

Warnings (1)
Serial number has unexpectedly changed (xxxxxxxxxxxxxxxx).
To reconcile this, use the RMA Device operation.

 

Environment

  • SGVA running 6.7.4.x and later
  • Management Center running 1.11.x and later

Cause

As of SGOS 6.7.4.x on VA’s an Appliance Identifier (Appliance ID) feature has been introduced. This was introduced explicitly for use by the MC product. It was added for use with SGVA offline licenses and future licensing feature implementations. The reason that this was introduced is because the serial number for offline SGVA units may not always be unique. Therefore, using the Appliance ID (which is based on the MAC address of SGVA unit's first interface) is a better way of establishing a unique ID. This was not present on SGOS 6.7.3.x and earlier. So only when upgrading to 6.7.4.x after already having been registered to the MC, this issue will happen. 

When connecting to the SGVA from the MC, it will send a "show version" command to the SGVA to identify the unit and the current version it's running. Being that the SG is now running 6.7.4.x which introduces the Appliance ID, the SG will send this ID and MC units running at least 1.11.x will know to use this appliance ID instead of the serial number. That is the reason for this prompt which is expected behavior
 

Other problems that may occur with use of the Appliance ID:

Since the appliance ID is actually based on the MAC address of the SGVA unit's first network adapter, it means the Appliance ID could change in the following cases:

  • The user physically replaced the network card
  • The user asks the hypervisor to change its MAC address
  • A Machine was incorrectly cloned resulting in duplicate machines with the same MAC

Note: As of the date of this article, this feature and associated behavior should only apply to SGVA units running offline licenses but in the advent of new features being introduced, that may change.

Resolution

To resolve this issue, simply press the Update Device button which will cause the MC device to associate the SGVA unit with the Appliance ID instead of the serial number.