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Tasks are Timing Out Because They Lose Connection to the CMDB.

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Article ID: 172296

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Updated On:

Products

Management Platform (Formerly known as Notification Server) Task Server

Issue/Introduction

Tasks are timing out because they lose connection to the CMDB. Also, Management Console task page would take a long time to load.

You cannot connect to a SQL server via HTTPS/SSL.

Operation 'Direct: Post' failed.

Protocol: HTTPS

Host: <Computer Host>

Path: /Altiris/ClientTaskServer/Register.aspx

Error type: SMP Server error

Error code: The server is currently paused (0x8004200E)

Error note: HTTP Status 200: 200 OK

Or an error stating “SQL connection failed on user <UserName> Pre-hand shake failed SSL connection.”

Cause

A previous Microsoft Security Update that had a known issue causing problems with TLS 1.2.

Microsoft Error (SQL Server error log):
TDSSNIClient initialization failed with error 0x80090331, status code 0x80. Reason: Unable to initialize SSL support. The client and server cannot communicate, because they do not possess a common algorithm.

Environment

Windows SQL Server 2012 - 2014

ITMS 8.1

SSL is in use.

Resolution

To fix these errors, please see the following Microsoft article - "FIX: You cannot use the Transport Layer Security protocol version 1.2 to connect to a server that is running SQL Server 2014 or SQL Server 2012