Messaging Gateway cannot install PKCS#7 SSL/TLS certificate
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Messaging Gateway cannot install PKCS#7 SSL/TLS certificate

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Article ID: 172252

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Updated On:

Products

Messaging Gateway

Issue/Introduction

SSL certificate in PKCS#7 (.p7b) format cannot be installed completely by Symantec Messaging Gateway (SMG).

Cause

The PKCS#7 certificate is not compatible with SMG, and the SMG cannot convert it on its own.

Certificates must be in x509/PEM format in order to be installed into the Messaging Gateway.

Resolution

Notice: These instructions are provided as a service to our customers. Symantec ECS will not provide assistance to convert certificate formats by phone, email, or chat. For more assistance, please contact your certificate authority.

 

Convert the PKCS7 certificate to x509/.pem file and import:

  1. Install OpenSSL (https://www.openssl.org/ for installation help) on the workstation, if not already installed.
  2. Copy the .p7b file into the same directory as the OpenSSL executable
  3. Run the command openssl pkcs7 -print_certs -in certificate.p7b -out certificate.pem, with certificate.p7b replaced by the name of the existing cert, and your name for the exported cert replacing certificate.pem (ex. converted_smg_cert.pem).
  4. Take the new certificate.pem file, and import into the Control Center of the SMG.

For more information, please refer to the "Setting up Certificates" chapter in the SMG Administration Guide.