Target icons are displayed with a lock when applying a Target to a Task or Policy
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Target icons are displayed with a lock when applying a Target to a Task or Policy

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Article ID: 172224

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Updated On:

Products

IT Management Suite

Issue/Introduction

When trying to apply a target to a task or policy, the target icons are displayed with a lock although the security role the user browsing the console is a member of is assigned to the target's scope. The lock icon implies that the user does not have rights to that Target.

Some companies have Targets created by one group and used by another group.  Those companies will have to change the scope of each Target created so that they can be used by another group.

 

Environment

  • 8.x

Cause

  • If the target's scope has a role with higher rights than the role the user logged into is in, the security on the target is locked.
  • It is not possible to setup Rights / Permissions to Targets in the Security Role Manager, as Targets are not an item in the list.

Resolution

The behavior is by design.

To workaround:

  1. Remove the security roles with higher rights from the target's scoping
  2. Clone the target
  3. View the Targets from Manage > Computer, right-click on the Target and choose a Task to assign to the Target