ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

REST API fails to correctly pull Linux client cidsDefsetVersion info

book

Article ID: 172203

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

A REST API can be created to pull AV and Client Intrusion Detection System (CIDS) version information.

cidsDefsetVersion="NULL"

Cause

CIDS detection isn't a part of the Linux client software, so no CIDS definitions exist on a Linux machine.

Environment

Endpoint Protection 14.x
Linux versions

Resolution

For Linux clients only AV definition version information is available.