MTA won't start after upgrade
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MTA won't start after upgrade

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Article ID: 172151

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Updated On:

Products

Messaging Gateway

Issue/Introduction

After upgrading Symantec Messaging Gateway (SMG) the MTA service fails to start. Port 25 is not accessible and Messaging Gateway (SMG) does not accept email.

  • When trying to start the MTA service at the command line:
    • "Error: Malformed MTA config XML: Can't use an undefined value as an ARRAY reference at /opt/Symantec/Brightmail/mta/lib/perl/SMS/MTA.pm line 1280."
  • In the SMG Control Center:

    • In (Status > Message Queues) the MTA status shows a red X followed by "The selected queue is disabled".

 

Cause

The upgrade in some rare instances, removes the domains from the Domain Authentication field in (Spam > Sender Authentication).

(NOTE: This issue may occur whether or not you have only the following domains selected)

Resolution

The resolution to this issue is to add at least one domain to the Sender Authentication domains list

  1. Log into the SMG Control Center as an administrator
  2. Go to Spam > Sender Authentication
  3. Add at least one domain to the Domain Authentication list.
  4. Click "Save".
  5. Then restart the MTA service on all affected scanners.
    1. Go to (Administration -> Configuration -> Select a scanner -> Services)
    2. Check MTA and click stop.
    3. Check MTA and click start.
  6. Or restart the MTA service from the command line.
    1. "service mta restart"