Unable to add ProxySG to Management Center after upgrading to version 1.11.1.4
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Unable to add ProxySG to Management Center after upgrading to version 1.11.1.4

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Article ID: 172041

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Updated On:

Products

Management Center

Issue/Introduction

Customer discovered that after upgrading from Management Center (MC) 1.9.1.x to 1.11.1.4 they where no longer able to add certain ProxySGs to MC.

GUI returns the error message

"The operation has timed out"

when trying to test the connection to the ProxySG.

 

The sg.log (when set to debug level) shows

 

[2018-07-09 15:24:04.176] WARN  TimeoutFactory-watchdog-00   com.bluecoat.cm.device.sgos6x.command.SshjSshSession             SG SSH connection timed out.  Closing client. Expect a subsequent trace.
[2018-07-09 15:24:05.201] DEBUG eviceJobExecutor-worker-0133 com.bluecoat.cm.device.sgos6x.command.SshSessionFactory          ssh://192.168.1.2:22 - Creating session
[2018-07-09 15:24:09.467] WARN  https-jsse-nio-8082-exec-5   com.bluecoat.cm.device.sgos6x.command.SshSessionFactory          Error while checking if session ssh://192.168.1.3:22 was released in enable mode.  Abandoning session. java.util.concurrent.TimeoutException: Timed out while waiting for one of ["#"]

Environment

ProxySG SGOS 6.5.10.4

MC 1.11.1.4

Cause

The customer had set up a banner page for ssh logins which included reserved characters

"########## You are connected to ProxyA! ###########"

 

As of MC 1.11 the hashes  (#) in the banner (or the ProxySG name) will prevent MC from completing the logging process to the ProxySG

 

Resolution

Remove the banner login or remove the hashes from the message