The Endpoint Protection Manager reports deadlocks on the COMPUTER_APPLICATION table
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The Endpoint Protection Manager reports deadlocks on the COMPUTER_APPLICATION table

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Article ID: 171944

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Updated On:

Products

Endpoint Protection

Issue/Introduction

The Endpoint Protection Manager (SEPM) reports multiple unexpected server errors.  Log entries show deadlocks on the COMPUTER_APPLICATION table. 

scm-server-0.log:

2018-06-23 10:37:43.632 THREAD 122 SEVERE: Unexpected server error.
com.sygate.scm.server.metadata.MetadataException: Transaction (Process ID 83) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.

sql trace contains: :


update COMPUTER_APPLICATION set CREATOR_SHA2=@P0 , DOWNLOAD_URL=@P1 , DETECTION=@P2 , USN=@P3 where DOMAIN_ID= @P4 AND APP_HASH= @P5 AND AGENT_ID= @P6 AND LOCATION_ID=@P7     </frame>
     <frame procname="unknown" line="1" sqlhandle="0x0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000">
unknown     </frame>
    </executionStack>

Cause

The SEPM fails to lock the COMPUTER_APPLICATION table properly when updating entries in the table.  This can lead to multiple SEPMs attempting to update the table at the same time. 

Resolution

This issue is fixed in Symantec Endpoint Protection 14.2.0.1 (14.2 MP1)  For information on how to obtain the latest build of Symantec Endpoint Protection, see Download the latest version of Symantec Endpoint Protection.

As a workaround, you can increase the interval between log uploads for this log type.  This should reduce the frequency of the deadlocks until a fix is available. 

  1. Edit conf.properties (C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat\etc) with this value: scm.timer.appcollection=3600
  2. Restart the Endpoint Protection Manager services. (semsrv, semwebsrv, semlaunchsrv, semapisrv)