Messaging Gateway error: Spamhunter module: Failure applying body regex rules.
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Messaging Gateway error: Spamhunter module: Failure applying body regex rules.

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Article ID: 171790

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Updated On: 07-31-2025

Products

Messaging Gateway Messaging Gateway for Service Providers

Issue/Introduction

When reviewing the Brightmail Engine logs in Messaging Gateway you find the following pairs of error messages logged within one second of each other:

  • Spamhunter module: Failure applying body regex rules.
  • DNS TXT query for "<hexnumber>.<domain>" failed unexpectedly.

 

Cause

This is caused by the legacy URL reputation filtering feature receiving an error when attempting to look up the reputation score of a URL in an email message that is being scanned.

It is important to note that the legacy URL reputation feature has been discontinued and has been replaced by the WebPulse feature.  See "Additional Information" below for more details.

Resolution

Workaround:

Disable URL reputation filtering in the SMG control center (Spam -> Scan Settings) Uncheck "Enable URL Reputation filtering" and click Save.

Recommended:
  • Verify DNS settings for the SMG are set to internal DNS servers by IP address.
  • Configure the internal DNS server to allow more connections from the IP address of the SMG.
  • Allow more bandwidth to the DNS server.
  • Verify that DNS traffic over port 53 is not blocked, throttled, or shaped in any way.

Additional Information

For more information on the WebPulse feature, which is replacing the legacy URL Reputation feature, see the following:

WebPulse usage information for Messaging Gateway