Messaging Gateway error: Spamhunter module: Failure applying body regex rules.
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Article ID: 171790
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Updated On:
Products
Messaging Gateway
Issue/Introduction
When reviewing the Brightmail Engine logs in Messaging Gateway you find the follow pairs of error messages logged within one second of each other:
Spamhunter module: Failure applying body regex rules.
DNS TXT query for "<hexnumber>.<domain>" failed unexpectedly.
Cause
This is caused by the URL reputation filtering feature receiving an error when attempting to look up the reputation score of a URL in an email message that is being scanned.
Resolution
Workaround:
Disable URL reputation filtering in the SMG control center (Spam -> Scan Settings) Uncheck "Enable URL Reputation filtering" and click Save.
Recommended:
Verify DNS settings for the SMG are set to internal DNS servers by IP address.
Configure the internal DNS server to allow more connections from the IP address of the SMG.
Allow more bandwidth to the DNS server.
Verify that DNS traffic over port 53 is not blocked, throttled, or shaped in any way.