"Unable to add socket watcher: Socket is closed." errors are in the logs
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"Unable to add socket watcher: Socket is closed." errors are in the logs

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Article ID: 171789

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Updated On: 11-01-2024

Products

IT Management Suite

Issue/Introduction

There are multiple errors that mention, "Error processing incoming tickle connection. Unable to add socket watcher: Socket is closed." when reviewing the Symantec Management Platform logs or the Site Server logs.

Error processing incoming tickle connection.

Unable to add socket watcher: Socket is closed.
[Altiris.DotNetLib.Sockets.SocketClosedException @ Altiris.DotNetLib]
at Altiris.DotNetLib.Sockets.SocketWatchThread.EnsureEntry(Socket socket, SocketEventCallback callback)
at Altiris.ClientTask.Server.RemoteClientTaskManager.OnAcceptClientConnection(Socket newSocket)

Exception logged from:
at Altiris.TaskManagement.Logging.AltirisServerLog.ReportException(Int32, String, String, Exception, String, Object[])...

Environment

ITMS 8.x

Cause

The, "Unable to add socket watcher: Socket is closed." error is coming from the AtrsHost.exe process which communicates with the Symantec Management Agents.

Resolution

To upgrade all the out-of-date Symantec Management Agents to the same version as the Management Platform.
The agent upgrade policies can be found in the console under: Settings > Agents/Plug-ins > Symantec Management Agent > Windows > Non Site Server.

Additional Information

"How to see what clients are not up-to-date with the plug-ins latest version" (KB 274349)