Error while disabling Webpulse: "WebPulse service or its health check is in use by policy"

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Article ID: 171677

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Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

The purpose of this article is to provide possible solutions for the error "WebPulse service or its health check is in use by policy" encountered while trying to disable Webpulse.

 

In the Event Log when trying to disable Webpulse looks as follows:

"Policy blocked stopping the DRTR service during provider removal."

Cause

There are two possible causes for this issue:

1-The DRTR health check is being referenced anywhere in policy.

2-The DRTR health check itself is preventing Webpulse from being disabled.

Resolution

1-The DRTR health check is being referenced anywhere in policy.

 

To check if DRTR is referenced in policy, you can go to the VPM, then go to a Web Access Layer and into de "Service" column, search for "Health Status Objects". If any of them reference the DRTR health check, make sure to remove them all before trying to disable Webpulse once again.

Another way to perform this is by going to the System Information file and search for this CPL code: "drtr.rating_service"=yes”. If this exists, it means there are still objects to be removed from the VPM.

 

2-The DRTR health check is preventing DRTR to be disabled.

 

In some rare cases, it may be necessary to disable the DRTR Health Check in order to be able to disable Webpulse.

This can be done from Configuration > Health Checks > General > drtr.rating_service > Edit > Disabled: Healthy > OK > Apply. After this, you should be able to disable and re-enable Webpulse.