ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

BCAAA upgrade uninstalls previous versions

book

Article ID: 171531

calendar_today

Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

BCAAA upgrade uninstalls previous versions, but you need previous versions to support appliances not upgraded yet.

When I try to upgrade my BCAAA server, the installation wizard indicates that it is uninstalling the previous versions of the software. However, I still need the previous versions to support the appliances that I do not plan to upgrade yet.

Resolution

Although the BCAAA installation wizard says that it is uninstalling previous versions of BCAAA during an upgrade, it will not remove the bcaaa.ini and bcaaa-nn.exe files for each version that was previously installed. This allows it to continue to run any previous versions of BCAAA that were installed on the server. After upgrading, your BCAAA server will continue to work with all SGOS versions it previously worked with.