Classification fields can not be expanded past item with '&' in it.

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Article ID: 171493

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Updated On:

Products

Workflow Solution ServiceDesk

Issue/Introduction

In ServiceDesk classification hierarchy data there is a classification with '&' in it. When this classification is selected, none of its sub-classifications can be selected.

Classification hierarchical data resides in the Hierarchy Data Service of Workflow:
Admin > Data > Hierarchy Data Service

Cause

Hierarchy Data item names are expected to contain '&' in encoded form as '&' to function properly. When item name contains '&', the EnsembleMenuSelect component responsible for showing the items fails to show it properly.

This will not happen when items are added from Hiererchy Data Service page. Such items, however, can be added when importing items in bulk.

Environment

ServiceDesk 8.x
Workflow 8.x

Resolution

To resolve the issue the item names must be changed to contain the expected '& instead of '&'.

The best way of doing that is in the Portal.

  1. Log into the Portal with administrator user.
  2. Navigate to Admin > Data > Hierarchy Data Service
  3. Find the problematic hierarchy item and click the edit icon to the right of the item
  4. Click Save (& in the item name will be automatically saved as it is supposed to)
  5. Note that as the data is cached IIS and Symantec Workflow Service need to be restarted for the changes in Hierarchy Data to take effect immediately.