There is a failure to run protect.PRECHECK when performing an upgrade to Data Loss Prevention 15.0

book

Article ID: 171448

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

When upgrading to Data Loss Prevention (DLP) 15.0 there is a failure when running the protect2.PRECHECK.

[ERROR] com.vontu.install.i4j.VerifyDBPermissionsAction [ID 124827]: SQLException while verifying Oracle permissions:

ORA-00942: table or view does not exist

ORA-06512: at "PROTECT.PRECHECK", line 192

ORA-06512: at line 1

[INFO] com.vontu.install.i4j.VerifyDBPermissionsAction [ID 124827]: Variable changed: oraclePermissionsErrorMessage=<Error>

Oracle Permissions Check Failed:

The database precheck has detected a problem. The upgrade has been canceled. Your

system remains on the current version. Please see the Troubleshooting section of

the Upgrade Guide for solutions.

</Error>[class java.lang.String]

Cause

The Protect user has insufficient privileges to run the prechecker.

Environment

DLP 14.6 MP1

DLP 15.0.0

Linux

Resolution

Add the permission “SYS.user_tab_privs“ to the Protect user.