Control Compliance Suite Vulnerability Manager (CCS VM) and ServiceNow connector

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Article ID: 171349

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Updated On:

Products

Control Compliance Suite Vulnerability Manager

Issue/Introduction

In configuring the CCS-VM console machine to use the ServiceNow connector(s) you are getting an error when testing the connection.

 

 

Asset Export: FAILED

Asset Result: Export failed for Asset ID 999999999

System.NullReferenceException: Object reference not set to an instance of an object.

   at eEye.RetinaCS.BusinessLogic.DataExport.SoapRequestBase.TryAgain(ISoapResponse response, Int32 failureCount)

   at eEye.RetinaCS.BusinessLogic.DataExport.SoapRequestBase.Post()

   at eEye.RetinaCS.BusinessLogic.DataExport.ServiceNowExporter.ExportItem(ServiceNowConnector serviceNowConnector, Object itemToExport, Object assetOrVulId, String& exportResult, DataExportItem dei, CookieContainer cookieJar)

 

Cause

Wrong URL being used for the asset and vulnerability URL settings in the ServiceNow configuration.


 

Environment

CCS-VM 12.3.1 and higher.

Resolution

The CCS-VM Third Party Integration Guide, that is shipped with 12.3.1 and 12.4.5 versions of CCS-VM, does not mention the correct URLs for entering in the configuration of the ServiceNow connector.  The correct URLs are:

Asset url:

    https://[servicenow instance name].service-now.com/bi_imp_set_computer.do?SOAP

 

Incident (AKA Vulnerability) url:

   https://[servicenow instance name].service-now.com/bi_imp_set_incident.do?SOAP

 

The CCS-VM Third Party Integration Guide also mentions a path to a CCS-VM update set file: %\Program Files(x86)\Symantec\Symantec CCS-VM\ServiceNow

This path contains an update set XML file that does not have the latest version of the ServiceNow connector.  Instead of using this file, please find attached to this article an updated version of the XML file that should be used instead.  The update set can be loaded into ServiceNow as mentioned in the wiki site: http://wiki.servicenow.com/index.php?title=Transferring_Update_Sets.

In the case that the older update set XML file has already been loaded into ServiceNow, it can be removed using the procedure outlined in the attached document "ServiceNowConnector_Update.docx".

NOTE: After installing the new CCS-VM update set into ServiceNow, a role called "symantec_integration_role" will appear in ServiceNow.  This role needs to be assigned to the account used to connect CCS-VM to ServiceNow.   This account is entered in the CCS-VM configuration page for the ServiceNow connectors.

 

 

Attachments

Symantec CCS-VM Integration V2.5.4.xml get_app
ServiceNowConnector_Update.docx get_app