Computers task history (for running jobs) is disappearing before (or soon after) a job completes
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Computers task history (for running jobs) is disappearing before (or soon after) a job completes

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Article ID: 171333

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Updated On:

Products

IT Management Suite

Issue/Introduction

Deployment Solution (DS) is being used extensively as is Task Management on the Symantec Management Platform (SMP) Server - with 18,000+ managed machines.

In order to ensure sufficient Task log data is being retained the administrator increased the purging to keep at least 10M rows in Task Instances.

Computer's task history (for running jobs) started disappearing soon after and in some cases before jobs with many tasks were able to complete.

The following settings were used for "Clean Up Task Data" (in the SMP Console under Settings>All settings>Notification Server>Task Settings):

  • Max working rows = 10M
  • Max summary rows = 500k
  • Minimum time period to keep the task instances/summaries = unchecked
  • Run cleanup task on demand = checked

Environment

ITMS 8.x

Cause

The issue was found to be with the list of task instances in the SMP Console for some jobs that were cleaned up by the “Clean up Task Data” task.

The TaskInstances tables may grow very quickly in environments with 10,000+ managed machines and intensive task usage, as the clean-up affects all of the records, even the recent ones.

Resolution

To mitigate these problems, the option “Minimum time period to keep the task instances/summaries” was added in ITMS 8.0 HF1 as shown here:

If this option is selected then with default setting of “1 Week” then the “Clean up Task Data” task should ignore all the records which are newer than 1 week and not remove them.