Computers task history (for running jobs) is disappearing soon after or before a job completes
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Computers task history (for running jobs) is disappearing soon after or before a job completes

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Article ID: 171333

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Updated On:

Products

IT Management Suite

Issue/Introduction

An environment was using Deployment Solution (DS) extensively and also Task Management on the Symantec Management Platform Server - with 18,000+ managed machines.

In order to ensure sufficient Task log data the administrator increased the purging to keep at least 10M rows in Task Instances.

Computer's task history (for running jobs) started disappearing soon after and in some cases before jobs with many tasks were able to complete.

The following settings were used for "Clean Up Task Data" (in the SMP Console under Settings>All settings>Notification Server>Task Settings):

  • Max working rows = 10M

  • Max summary rows = 500k

  • Minimum time period to keep the task instances/summaries = unchecked

  • Run cleanup task on demand = checked

Environment

ITMS 8.0 HF6 and later

Cause

The issue is with the list of task instances in the console for some jobs which were cleaned up by the “Clean up Task Data” task.

TaskInstances tables may grow very quickly in environments with many clients (10,000+) and intensive task usage clean-up affects all of the records, even the recent ones.

Resolution

To mitigate these problems, Symantec Engineering added the option “Minimum time period to keep the task instances/summaries” in 8.0.HF1 as seen:

If this new option is selected then with default “1 Week” setting Cleanup Task should ignore all the records which are newer than 1 week and not remove them.

Symantec Management Platform 8.1 was further optimized to handle larger amounts of tasks with less or no performance impacts.