Computers task history (for running jobs) is disappearing soon after or before a job completes

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Article ID: 171333

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Updated On:

Products

Management Platform (Formerly known as Notification Server) Task Server

Issue/Introduction

In an environment using Deployment Solution (DS) extensively and Task Management as well on the Symantec Management Platform Server. e.x. With 18,000+ managed machines.
In order to ensure sufficient Task log the administrator increased the purging to keep at least 10M rows in Task Instances.

Computers task history (for running jobs) started disappearing soon after or before jobs with many tasks completed.

The following settings are used for "Clean Up Task Data" (under Settings>All settings>Notification Server>Task Settings):

  • Max working rows = 10M

  • Max summary rows = 500k

  • Minimum time period to keep the task instance = unchecked

  • Run cleanup task on demand = checked

Cause

The issue is with the list of task instances in console for some job which were cleaned up by the “Clean up Task Data” task.

TaskInstances tables may grows very quickly in environments with many clients (10000+) and intensive tasks usage clean-up affects all the records, even the recent ones.

Environment

Symantec Management Platform 8.0 HF6 and later

Resolution

To mitigate such problem Symantec Engineering added the option “Minimum time period to keep the task instances/summaries” in 8.0.HF1:

If this option is selected then with default “1 Week” setting clean-up task should ignore all the records which are newer than 1 week.

Symantec Management Platform 8.1 was further optimized to handle larger amounts of tasks with less or no performance impacts.
 

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