Inventory File data shows files existing on computers where the file has been upgraded or removed
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Inventory File data shows files existing on computers where the file has been upgraded or removed

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Article ID: 171283

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Updated On:

Products

Inventory Solution IT Management Suite

Issue/Introduction

Computers show file data for files that have either been upgraded or deleted and no longer exist on the system. This can cause inaccurate reporting when those reports review the file data as part of the criteria.

Environment

ITMS 8.x

Cause

Outdated or incorrectly synced inventory can cause this.
Losing the NSE that instructs the server to remove the rows for upgraded or deleted files can also cause this.

Resolution

There are two main sources of file data in Inventory Solution. First, the Windows Add Remove Programs "Installed Software" scan will pick up files associated with installed software, creating file resources. The second is the File properties scan. The resolution is different depending on where the problem stems from. If you are unsure, use both methods.

METHOD for Installed Software

This method is simple. For Installed Software, be sure to schedule a Full Inventory or Full Software Inventory to execute on affected clients. To ensure the policy you are running will resolve this, see these steps:

  1. In the Inventory Policy or Task, ensure the option "Software - Windows Add/Remove Programs and UNIX/Linux/Mac software packages" is checked.
  2. Go into Advanced options.
  3. If checked, uncheck the option: Send inventory changes (deltas) only.
  4. Click OK to save the changes, and Save changes to save the Policy or Task.
  5. Run the policy or task against every system to ensure updated inventory is sent up.

METHOD for File Scan

In 8.5 a Full Inventory, just as the steps above, will account for files, but until then the process needs to be somewhat manual. NOTE: This process will remove computer's association to file resources, thus it is vital that all systems report in a full inventory as per the steps. Follow these steps:

  1. Open SQL Enterprise Studio and open a query window against the Symantec database.
  2. Run the following query that will delete the data from ResourceUpdateSummary (this table contains a hash that can prevent data from being inserted into the database):
    DELETE FROM ResourceUpdateSummary
    WHERE InventoryClassGuid = 'A3855A05-D687-4969-8356-94717DF261F2' (where GUID 'A3855A05-D687-4969-8356-94717DF261F2' stands for Installed File Details)
  3. Second, delete the data that connects the computer resource to the file data (no file data itself is affected save for the instance count):
    TRUNCATE TABLE Inv_Installed_File_Details
  4. In the Inventory Policy or Task, ensure the option "Software - Windows Add/Remove Programs and UNIX/Linux/Mac software packages" is checked.
  5. Ensure that the option "File properties - manufacturer, version, size, internal name, etc." is checked.
  6. Go into Advanced options.
  7. If checked, uncheck the option: Send inventory changes (deltas) only.
  8. Click OK to save the changes, and Save changes to save the Policy or Task.
  9. Run the policy or task against every system to ensure updated inventory is sent up.