Unable to Open ServiceDesk Since Upgrade to 8.1. 404 error message when attempting to access.

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Article ID: 171250

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Updated On:

Products

ServiceDesk

Issue/Introduction

After upgrading Servicedesk installation to 8.1 RU5, licensing was failing, it was impossible to open the tech feeder form, or basic incident forms, and web service calls to populate locations, departments and business services were failing.  A variety of error messages were also displayed. pplication Name : SD.DataServices
Process ID : 5332
Date :14/03/2018 17:06:39
Log Level :Error
Log Category :LogicBase.Components.Default.Logging.CreateLogEntryComponent
Machine Name :XXXXXXX
Message : 
Location Search failed with the following: could not deserialize: LogicBase.Core.IOrchestrationComponent[]
 
LogicBase.Framework.ObjectDeserializationError: could not deserialize: LogicBase.Core.IOrchestrationComponent[] ---> System.Exception: could not find type Altiris.TaskComponents.ExecuteSendBasicInventoryComponent
   at LogicBase.Framework.ArrayTypeConverter.GetObject(ObjectStorageContainer container, ObjectStorageObjectData values, Type arrayType, ObjectStorageErrorHandler errorHandler)
   at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter)
   --- End of inner exception stack trace ---

Application Name : SD.DataServices
Process ID : 5332
Date :14/03/2018 17:14:17
Log Level :Error
Log Category :LogicBase.Components.Default.Logging.CreateLogEntryComponent
Machine Name : XXXXXXX
Message : 
Exception Component: End                          
 
Get Users Details failed with the following: could not deserialize: LogicBase.Core.IOrchestrationComponent[] 
 
LogicBase.Framework.ObjectDeserializationError: could not deserialize: LogicBase.Core.IOrchestrationComponent[] ---> System.Exception: could not find type Altiris.TaskComponents.ExecuteSendBasicInventoryComponent
   at LogicBase.Framework.ArrayTypeConverter.GetObject(ObjectStorageContainer container, ObjectStorageObjectData values, Type arrayType, ObjectStorageErrorHandler errorHandler)
   at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter)
   --- End of inner exception stack trace ---

 

Cause

Duplicate Installation locations.  After further review, in IIS,  it was discovered that the virtual directories IIS was using were found on both the C: and D: drives.  About half of the Servicedesk applications were installed on:

C:\Program Files\Symantec\Workflow\WorkflowDeploy\Release\Project Name...

However, the primary install location was:
D:\Program Files\Symantec\Workflow\WorkflowDeploy\Release\Project Name...

Environment

Upgrade from 7.5 Sp1 to 8.1Ru5

Resolution

Edited the virtual directory configuration in IIS to reflect the proper location.  This was done by the following procedure:

1. Open IIS Manager
2. Expand Server>Sites>Default Web Site
3. Right-Click on Each Application, and click Manage Application>Advanced Settings
4. Under the General section, verify that the physical path was correct.  In this specific case, the drive reference should have been D:, but was set to C: instead.  Simply click into the path and change the drive reference, then click OK.
5.  Repeat steps 3-4 for each application
6.  Restart the Server.