Get Computer Info component no longer exists in Workflow 8.1 RU3 and newer.

book

Article ID: 171166

calendar_today

Updated On:

Products

Workflow Solution

Issue/Introduction

Get Computer Info component (from LogicBase.Components.SystemUtilities.dll) is there in Workflow 8.1 RU2 but no longer exists in Workflow 8.1 RU3 and newer.

Cause

This component was removed as a part of component cleanup effort. Unfortunately, this particular component is used quite extensively is projects and slipped through the cracks when reviewing the proposed removals.

Environment

Workflow 8.1 RU3
Workflow 8.1 RU4
Workflow 8.1 RU5
Workflow 8.1 RU6

Resolution

Symantec Engineering is working on rebuilding the same functionality in a component in a future Workflow version.

Workaround:

The component does exist in Workflow 8.1 RU2 (version 8.1.5210.0) and in a component library that has few or no ties to other libraries or components. As a workaround, older version of the library from 8.1 RU2 can be used on newer versions of Workflow Server by replacing newer version of the same library.

  1. Download the attached LogicBase.Components.SystemUtilities.zip and unzip it.
  2. Stop both IIS and Symantec Workflow Server service.
  3. Copy the LogicBase.Components.SystemUtilities.dll from downloaded zip to \Workflow\Shared\Components\ folder (default full location: %ProgramFiles%\Symantec\Workflow\Shared\Components\) overwriting the version of the same library in there.
  4. Start IIS and Symantec Workflow Server service.

 

Attachments

LogicBase.Components.SystemUtilities.zip get_app