Error making exception in Control Compliance Suite (CCS) from the Detailed Evidence dialogue box

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Article ID: 171101

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

Making an exception from the Detailed Evidence dialogue box results in an error when trying to save the exception by clicking FINISH.

 

WARNING:

This may have occurred due to any of the following reasons:

1. CCS Application Server is not running or responding.

2. CCS Directory service is not running or responding.

3. Connection to the database server could not be established.

4. You may not have access to one or more of the above services.


 

Cause

Max Array and Max String settings too small to create buffer sizes large enough to handle the exception data being retrieved from the database.


 

Environment

CCS 11.x up to CCS 12.0.1

 

Resolution

Backup and then edit the <installation path>\Symantec\CCS\Reporting and Analytics\Application Server\ApplicationsBinding.config    file and increase the following settings near the top of the file:

 

BEFORE:

<binding name="common_WSHttpBinding" closeTimeout="00:01:00"
              openTimeout="00:01:00" receiveTimeout="00:10:00"
sendTimeout="00:01:00"
              bypassProxyOnLocal="false" transactionFlow="false"
hostNameComparisonMode="StrongWildcard"
              maxBufferPoolSize="67108864" maxReceivedMessageSize="67108864"
              messageEncoding="Mtom" textEncoding="utf-8" useDefaultWebProxy="true"
              allowCookies="false">
          <readerQuotas maxDepth="32" maxStringContentLength="8192"
maxArrayLength="16384"
            maxBytesPerRead="4096" maxNameTableCharCount="16384"/>


AFTER:

<binding name="common_WSHttpBinding" closeTimeout="00:01:00"
              openTimeout="00:01:00" receiveTimeout="00:10:00"
sendTimeout="00:01:00"
              bypassProxyOnLocal="false" transactionFlow="false"
hostNameComparisonMode="StrongWildcard"
              maxBufferPoolSize="67108864" maxReceivedMessageSize="67108864"
              messageEncoding="Mtom" textEncoding="utf-8" useDefaultWebProxy="true"
              allowCookies="false">
          <readerQuotas maxDepth="32" maxStringContentLength="253535353"
maxArrayLength="253535353"
            maxBytesPerRead="4096" maxNameTableCharCount="253535353"/>
        </binding>

 

Also replace all remaining MaxArrayLength  and MaxNameTableCharCount having a value of 16384 with the value 253535353..... throughout the entire file.

Restart the Symantec Application Server service on the application server.

By replacing these settings with the larger value, CCS will be able to pull the larger exception data and create the exception.