Failed dependencies error when upgrading Encryption Management Server

book

Article ID: 171084

calendar_today

Updated On:

Products

Encryption Management Server Gateway Email Encryption

Issue/Introduction

When upgrading Encryption Management Server using a PUP file, a Failed dependencies error appears in the Reporting / Logs / Update log.

The update log contains these entries:

2018/02/23 17:57:37 +00:00  NOTICE pgp/update[21339]: error: Failed dependencies:
2018/02/23 17:57:37 +00:00  NOTICE pgp/update[21339]: libgnutls.so.26 is needed by (installed) cups-libs-1:1.4.2-72.el6.i686
2018/02/23 17:57:37 +00:00  NOTICE pgp/update[21339]: libgnutls.so.26 is needed by (installed) tigervnc-server-1.1.0-24.el6.i686
2018/02/23 17:57:37 +00:00  NOTICE pgp/update[21339]: libgnutls.so.26(GNUTLS_1_4) is needed by (installed) cups-libs-1:1.4.2-72.el6.i686
2018/02/23 17:57:37 +00:00  NOTICE pgp/update[21339]: libgnutls.so.26(GNUTLS_1_4) is needed by (installed) tigervnc-server-1.1.0-24.el6.i686

Cause

The script /var/lib/ovid/customization/pgpupdate-post-install-hook.sh contains an entry to try to uninstall the package gnutls. This script runs immediately after the upgrade. The entry to uninstall gnutls fails because it is required by other packages.

Environment

  • Encryption Management Server 3.4 and above.
  • Data restored from a backup of 3.4 or 3.3.2 at some point in the server's history.

Resolution

This error can be ignored because the error is a result of a failure to uninstall the gnutls package and this package should not be uninstalled.