Package servers and Client machines sending excessive Config Requests while trying to get their agent connection profiles

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Article ID: 171023

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

The customer noticed that multiple package servers and client machines were sending excessive Config Requests. Agents show the correct configuration request value of 2 hours interval but seems to be sending requests far more often.
Querying the Evt_NS_Client_Config_Request table shows nearly 300,000 config requests spanning 3 days.

The agents themselves are connected and working just fine as far as getting packages and getting policies, etc but the agent logs shows entries like this constantly:

Entry 1:
Connection profile '{b29618e4-5b36-4364-a4fc-a97dc6bd3411}' has been successfully imported from '{B5FA615D-476A-4C8A-AD64-E148607B7667}'
------------------------------------------------------------------------------
Entry 2:
Profile '{B5FA615D-476A-4C8A-AD64-E148607B7667}' was downloaded
------------------------------------------------------------------------------
Entry 3:
Failed to read revision from profile '{B5FA615D-476A-4C8A-AD64-148607B7667}', error: The system cannot find the file specified (0x00000002)
-----------------------------------------------------------------------------

Entry 1:
Connection profile '{b29618e4-5b36-4364-a4fc-a97dc6bd3411}' has been successfully imported from '{B5FA615D-476A-4C8A-AD64-E148607B7667}'
----------------------------------------------------------------------------
Date: 1/26/2018 11:22:07 AM, Tick Count: 328365718 (3.19:12:45.7180000), Size: 359 B
Process: AeXNSAgent.exe (7940), Thread ID: 6980, Module: AeXNSAgent.exe
Priority: 4, Source: Agent

Entry 2:
Profile '{B5FA615D-476A-4C8A-AD64-E148607B7667}' was downloaded
----------------------------------------------------------------------------
Date: 1/26/2018 11:22:07 AM, Tick Count: 328365718 (3.19:12:45.7180000), Size: 300 B
Process: AeXNSAgent.exe (7940), Thread ID: 6980, Module: AeXNetComms.dll
Priority: 8, Source: ConnectionProfile

Entry 3:
Failed to read revision from profile '{B5FA615D-476A-4C8A-AD64-E148607B7667}', error: The system cannot find the file specified (0x00000002)
----------------------------------------------------------------------------

Date: 1/26/2018 11:22:07 AM, Tick Count: 328365718 (3.19:12:45.7180000), Size: 377 B
Process: AeXNSAgent.exe (7940), Thread ID: 6980, Module: AeXNetComms.dll
Priority: 1, Source: ConnectionProfile

Cause

The Clients are requesting the agent connection profile, but instead receive the whole "Initial Settings" policy which contain the SMP communication profile inside and only then
the required SS profile. SMP code do not respect the request flag which requires to return only the requested item.

Environment

ITMS 8.1 RU5 and prior 8.1 versions.

Resolution

This issue has been reported to the Symantec Development team. A fix has been scheduled for ITMS 8.1 RU6.

The current workaround is as follows:

  1. Go to Settings\Agents/Plug-ins\Symantec Management Agent\Settings\Targeted Agent Settings and disable the "(Initial Settings)" policy
  2. Wait for the next Delta and Policy Resource Update so the change can be added to the client configurations
  3. On one of the affected machines, refresh its configuration and see if the issue is still persistent.

 

Note: in case the workaround is not possible, here is a pointfix available for 8.1 RU5. See attachment. This pointfix verifies that agents receive communication profiles with (Initial Settings) policy enabled. As well verifies that if site server communication profile is removed from agents registry - it will be recreated.(agent service stopped  during removal).

  1. Retrieve files from the archive to the NS hard drive.
  2. Run as administrator PFinstaller2.exe, click on ‘Install’ button

Note! PF contains only server-side fixes and do not require upgrade of clients or Site Servers.

 

Attachments

Pointfix_eTrack4157629_8.1_RU5_SMP.zip get_app