DS 8.1 RU5 - After upgrading to RU5 on non-English environment, all clients booted into DS Automation are not able to register and process any tasks

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Article ID: 171009

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Updated On:

Products

Deployment Solution

Issue/Introduction

After applying the RU5 upgrade on 8.1 installation, any client booted into DS Automation - would fail to obtain Resource Guid - thus will fail to Register to Task Server and execute any assigned tasks.

On DS Automation logs and on SMP Server Logs following informational message is logged:

Response of CreateResource == <error number=""8000FFFF""></error>","Altiris.Deployment.Web.Services.GetResourceGuid.getResponseXML","Symantec.Deployment.Web.Services.dll"

If Verbose Logging is enabled on SMP Server - following line will be visible after Deployment Solution: CreateResource.aspx request:

"Unable to process CreateResource request: Unexpected end of file has occurred. The following elements are not closed: resource. Line 1, position 984.

Unexpected end of file has occurred. The following elements are not closed: resource. Line 1, position 984.

Cause

In RU5 additional security have been added, where in order to process the call, account information have to be gathered and passed through.

And since DS Web service is now gathering this account name with non-english character, it was failing to properly send it further to NS Agent Web service.

Environment

8.1 RU5 upgraded

SMP Installed on non-English OS (accounts having special characters), for example for German Windows OS - NT-AUTHORITY would be named NT-AUTORITÄT

Resolution

Symantec development is aware of this issue and released pointfix for the DS 8.1 RU5 release.

REQUIREMENT

DS 8.1 RU5 installed


HOW TO INSTALL THIS POINTFIX

1.    Extract files from the archive to the NS hard drive.
2.    Make sure PointFix is extracted not to Altiris install directory (or any subfolder to it)!!!
3.    Execute PFInstaller.exe under user with administrative privileges.
4.    Accept UAC (User Account Control) prompt, select Install Files. Old files will be replaced with the new ones. Log.txt will be created at the same location where PFinstaller is.

After installation of PointFix computers booted into DS Automation - will be able to obtain Resource Guid - and communicate with Task Server and perform Package Server requests.

HOW TO UNINSTALL

1.    Execute PFInstaller.exe under user with administrative privileges.
2.    Accept UAC (User Account Control) prompt, select Uninstall Files.

Note: This fix will be also added in future versions starting from 8.1 RU6

Attachments

8.1_RU5_DS_PF4159489.zip get_app