Login to SEPM with remote Java console is taking very long time since upgrade to SEP 14.0.1 (RU1)

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Article ID: 170989

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Updated On:

Products

Endpoint Protection

Issue/Introduction

You notice that logging into SEPM with a remote Java console is taking much longer since SEPM has been upgraded to 14.0.1 RU1.

The problem is present only with full-administrator users, logging in from remote machines. It's not present when logging to the local Java console on SEPM server machine or with limited/standard administrator users.

 

Looking at the SEPM Java console logs, you notice connection / timeout errors in the REST API login process:

 

%TEMP%\scm-ui-YYYY-MM-DD-HH-MM-SS-xyz.log

=========================================

8-feb-2018 11.17.13 GUIManager INFO: performRestApiLogin begin...
8-feb-2018 11.17.13 RESTAPILoginManager INFO: REST API login start...
8-feb-2018 11.17.34 RESTAPILoginManager SEVERE: REST API login error!
8-feb-2018 11.17.34 RESTAPILoginManager SEVERE: Failed to connect to the server.
 
Make sure that the server is running and your session has not timed out.
If you can reach the server but cannot log on, make sure that you provided the correct parameters.
If you are experiencing network issues, contact your system administrator. ErrorCode: 0x80020000
8-feb-2018 11.17.34 ExceptionHandler SEVERE: Root cause of the exception: Connection timed out: connect
8-feb-2018 11.17.34 RESTAPILoginManager INFO: REST API login done!
8-feb-2018 11.17.34 GUIManager SEVERE: REST API login process returned null API user token!
8-feb-2018 11.17.34 GUIManager SEVERE: getAccessToken #0 error: 
com.sygate.scm.console.util.ConsoleException: REST API login process returned null API user token.
at com.sygate.scm.console.util.GUIManager.performRestApiLogin(GUIManager.java:2924)
at com.sygate.scm.console.util.GUIManager.getAccessToken(GUIManager.java:2990)
at com.sygate.scm.console.ui.monitoring.Browser.getTokenKeyMap(Browser.java:580)
at com.sygate.scm.console.ui.monitoring.Browser.preprocessURL(Browser.java:492)
at com.sygate.scm.console.ui.MainPanel.createDynamicImageIcon(MainPanel.java:1321)
at com.sygate.scm.console.ui.MainPanel.createButton(MainPanel.java:1290)
at com.sygate.scm.console.ui.MainPanel.createDynamicPanel(MainPanel.java:1135)
at com.sygate.scm.console.ui.MainPanel.initializePanels(MainPanel.java:970)
at com.sygate.scm.console.ui.MainPanel.initialize(MainPanel.java:834)
at com.sygate.scm.console.ui.MainPanel.<init>(MainPanel.java:324)
at com.sygate.scm.console.ui.LoginPanel.setMainPanel(LoginPanel.java:1360)
at com.sygate.scm.console.ui.LoginPanel.access$900(LoginPanel.java:118)
at com.sygate.scm.console.ui.LoginPanel$7$1.finished(LoginPanel.java:729)
at com.sygate.scm.util.SwingWorker$1.run(SwingWorker.java:140)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.sygate.scm.console.util.KeepAlive$1.dispatchEvent(KeepAlive.java:78)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
 

 

Cause

The most common cause of the slow login time and these errors is missing connectivity to SEPM server port 8446.

This is a requirement added from SEP 14.0.1 RU1.

See for a full list of ports used by SEP the article: 

About the communication ports that Symantec Endpoint Protection uses
http://www.symantec.com/docs/HOWTO81103

 

The problem could be due also to "Symantec Endpoint Protection Manager API Service" (semapisrv) not running on SEPM server machine.

Please ensure that this service is running, set with "Startup Type: Automatic" and listening to TCP port 8446.

 

Resolution

Ensure connectivity from the machine running remote SEPM Java console to SEPM server port 8446 TCP.

Ensure that "Symantec Endpoint Protection Manager API Service" (semapisrv) is running on SEPM server machine.