Add the option for users to disable or enable CloudSWG WSS Agent
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Article ID: 170969
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Updated On:
Products
Cloud Secure Web Gateway - Cloud SWG
Issue/Introduction
You want to display the option for users to disable or enable the CloudSWG WSS Agent (WSSA):
In the case of an environment causing connection issues when the WSSA client is Active, you can configure CloudSWG to allow users to disable the WSS Agent.
NOTE: The Cloud SWG WSS Agent remains disabled until reboot, or until the user manually enables it again.
You may have previously enabled this "disable" option for WSSA, and you now want to revoke that option.
Cause
When the option for users to disable the WSS Agent is configured:
If the WSS Agent (WSSA) is disabled, WSSA remains disabled until the client computer reboots or the user manually re-enables it.
Applies to all CloudSWG agents belonging to the tenant:
You cannot selectively target which users receive the ability to disable WSS Agent option (this is a global setting per tenant).
When the option for users to disable the WSS Agent is removed/hidden:
Users will not see the option to disable the WSS Agent.
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Resolution
Log in to CloudSWG Portal: https://portal.threatpulse.com
Go to Connectivity -> Agent Settings
Under the End User Permissions, you will find the option: "Allow agent to be disabled by end user"
Check (enable) this option to allow users to disable the WSS Agent manually