Add the option for users to disable or enable Cloud SWG (Previously known as WSS) Agent
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Add the option for users to disable or enable Cloud SWG (Previously known as WSS) Agent

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Article ID: 170969

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

You want to display the option for users to disable or enable Cloud SWG (Previously known as WSS) Agent :

  • In the case of an environment causing connection issues or prevent the Unified Agent from passing web traffic to Cloud SWG (formerly known as WSS), you can configure Cloud SWG to allow employees to disable Cloud SWG Agent should connection issues occur.
    • NOTE - Cloud SWG agent remains disabled until user manually enables it again.
  • You may have added this option and want to revoke that option.

Environment

The displaying of the enable or disable Cloud SWG agent (WSS Agent) option is only available for Windows 7.x, 8.x, 10.x, and OSX 10.9 or later.

Cause

When the option for users to disable or enable Cloud SWG Agent (WSS Agent) is set to enabled:

  • If the Cloud SWG Agent (WSS Agent) is disabled, it remains disabled until the client computer reboots or the user manually enables it from the Cloud SWG Agent (WSS Agent) interface.

  • Applies to all Cloud SWG agents belonging to the tenant

    • NOTE: You cannot selectively target which installations receive the ability to view the disable Cloud SWG agent option.

When the option for users to disable or enable Cloud SWG agent is set to disable:

  • Users will not see the option to disable Cloud SWG agent.

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Resolution

  1. Log in to Cloud SWG portal (portal.threatpulse.com)
  2. Go to Connectivity -> Agent Settings -> End user permissions
  3. Under the End User Permissions, you will find option "Allow agents to be disabled by end user"
  • Check this option to allow users ability to disable and enable Cloud SWG Agent (WSS Agent) manually
  • Uncheck this option to prevent users from disabling the agent manually.