Endpoint Protection Auto-Protect fails to compile on 4.x, and newer, kernels for Ubuntu.

book

Article ID: 170875

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

When attempting to install Symantec Endpoint Protection for Linux (SEPFL) on Ubuntu systems that run a 4.x Linux Kernel, the Auto-Protect build script fails.  Attempting to manually run the build script results in the same errors.

The following kernel versions have been identified to have issues with the SEP for Linux auto-compile and manual compile options.

  • 4.8
  • 4.11
  • 4.13
  • 4.15
  • 4.18
  • 5.0

Environment

  • Ubuntu Linux Operating System
  • Kernels in the 4.x and up range

Resolution

This issue is fixed in Symantec Endpoint Protection 14.2 RU2 MP1. For information on how to obtain the latest build of Symantec Endpoint Protection, see Download the latest version of Symantec software here.

Kernel Version Fixed Build
4.8 14 RU1
4.11 14 RU1 MP2
4.13 (up to -36-generic) 14.2
4.13 (-37-generic+) 14.2 MP1
4.15 14.2 RU1
4.18 14.2 RU2 MP1
5.0 14.2 RU2 MP1