Loosing Data Center Security (DCS) Agent communication after upgrading Symantec EndPoint Protection (SEP) agent

book

Article ID: 170828

calendar_today

Updated On:

Products

Endpoint Protection Data Center Security Server Advanced

Issue/Introduction

Upgrading from SEP 14RU1 to 14RU1 MP1 breaks the functionality of DCS Agent 6.7 Agent

DCS Agent drivers and IPS,IDS,Util services are not loaded on rebooting machine after SEP upgrade:

Agent drivers are not loaded and IPS feature is not working:
C:\Users\Administrator.DC2016>sc query sisipsdriver
[SC] EnumQueryServicesStatus:OpenService FAILED 1060: The specified service does not exist as an installed service.

Cause

During SEP upgrade, some registry entries belonging to DCS Agent are removed by SEP installer.

Environment

Data Center Security 6.7 Windows Agent

 

Resolution

Workaround (to avoid problem):

Before upgrading SEP Client, you need to edit the package to remove a feature set. In the SEPM Console, go to Admin -> Client Install Feature Set :

Create a new feature set (Or edit a custom one) and unselect "Application Hardening". Save your feature set and use it in creating/exporting packages.

Solution (if issue occured):

Only option is to uninstall DCS and then re-install DCS. (The repair function will not work)

 

Attachments

Export-Import SDCSSA registry keys.zip get_app