In the SMP Console under Settings> Deployment the names next to package icons are not showing up
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In the SMP Console under Settings> Deployment the names next to package icons are not showing up

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Article ID: 170812

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Updated On:

Products

IT Management Suite

Issue/Introduction

There is an issue with the SMP Console where there are specific views not showing when under the Settings > All Settings section.  For example, under the Deployment Solution section of the tree on the left hand side, when clicking on folders what should appear on the right hand side does not appear.  An error appears instead.  When you drills down on these folders the sub-categories only show their icon and not the wording that goes with it: 

The affected items seems to be any one that has an icon for packages like under Settings>Deployment>Disk Images OR Settings>Agents/Plug-ins>Symantec Management Agent>Windows:

           

Environment

ITMS 8.1 RU5 or later

Cause

Unknown. There is a possibility that there was an issue while initially configuring the product during the upgrade.

When a profile trace was looked at, we noticed that these icons were failing to load properly while we were trying to load localization. We tried changing the browser language (from English to Spanish) and the issue went away. We tried switching to English-UK and English-Australia and the issue came back. We changed to Portuguese and the issue went away.

We looked at these package association type and we found that CoreStrings.config (under ..\program files\altiris\notification server\config) is the one that adds its references. In order to run the CoreStrings.config we had to actually run CoreSolution.config in order to call the necessary components.

Resolution

In order to properly link these associations for these packages references, we had to run a reconfiguration on the following config files:

  1. Run aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\CoreSolution.config" and after it run as well:
    • aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\NS_Update.config"
    • aexconfig /configure "C:\Program Files\Altiris\Notification Server\Config\NS_Hotfix.config"

NOTE: If the steps provided here don't solve the issue, please refer to the following KB article under the Additional Information section below.

Additional Information

172055 Console error: Unable to cast object of type 'System.DBNull' to type 'System.String'