Symantec.CSM.ConfigureServiceAccount.exe error: Directory not Found: 'Could not locate the Encryption Management Service Config Temp directory'.
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Symantec.CSM.ConfigureServiceAccount.exe error: Directory not Found: 'Could not locate the Encryption Management Service Config Temp directory'.

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Article ID: 170760

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Updated On:

Products

Control Compliance Suite Control Compliance Suite Standards Server Control Compliance Suite Standards Database Control Compliance Suite Standards Module

Issue/Introduction

Control Compliance Suite (CCS)

While configuring the CCS service accounts, the tool Symantec.CSM.ConfigureServiceAccount.exe throws an error just after entering the passphrase; Directory not Found: Could not locate the Encryption Management Service Config Temp directory.

 

Directory not Found: Could not locate the Encryption Management Service Config Temp 

 

Environment

CCS 12.6.x

CCS 12.7

 

Cause

The tool tries to create two directories in the windows directory. On a default installed or configured Windows system this will succeed without problem but on a hardened system this issue can occur. 

 

Resolution

Before running the Utility, create the following two directories in Windows root directory on the Application Server.

C:\Windows\EncryptionManagementService\ConfigTemp

C:\Windows\Application Server\AppServerConfigTemp

 

After the utility completes, do the following before starting the CCS Application Server services:

  1. Copy the files from the C:\Windows\EncryptionManagementService\ConfigTemp folder to the <InstallDir>:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\EncryptionManagementService\ConfigTemp directory.

  2. Copy the files from the C:\Windows\Application Server\AppServerConfigTemp folder to the <InstallDir>\Symantec\CCS\Reporting and Analytics\Application Server\AppServerConfigTemp directory.