Updates from 10.6.1 to 10.6.3 fail

book

Article ID: 170721

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

Attempts to update Messaging Gateway (SMG) 10.6.1-4 to SMG 10.6.3-4 fails with a dependency error.
Updating SMG 10.6.1 to SMG 10.6.4 works as expected.

smgsc1> update -v "10.6.3-2" download
...
Checking requirements
Total Size Required:               3.5 G
Total Size Available:               34 G
Error: Package: sms-appliance-release-10.6.3-2.noarch (symrepo_64_symc)
           Requires: msys-ecelerity-logging-pe_logger = 4.2.25.57347-1
           Removing: msys-ecelerity-logging-pe_logger-4.2.1.51715-1.x86_64 (@symrepo_64_msys)
               msys-ecelerity-logging-pe_logger = 4.2.1.51715-1
           Updated By: msys-ecelerity-logging-pe_logger-4.2.34.61137-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-logging-pe_logger = 4.2.34.61137-1
           Available: msys-ecelerity-logging-pe_logger-4.2.24.56625-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-logging-pe_logger = 4.2.24.56625-1
           Available: msys-ecelerity-logging-pe_logger-4.2.25.57347-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-logging-pe_logger = 4.2.25.57347-1
Error: Package: sms-appliance-release-10.6.3-2.noarch (symrepo_64_symc)
           Requires: msys-ecelerity-modules = 4.2.25.57347-1
           Removing: msys-ecelerity-modules-4.2.1.51715-1.x86_64 (@symrepo_64_msys)
               msys-ecelerity-modules = 4.2.1.51715-1
           Updated By: msys-ecelerity-modules-4.2.34.61137-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-modules = 4.2.34.61137-1
           Available: msys-ecelerity-modules-4.2.24.56625-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-modules = 4.2.24.56625-1
           Available: msys-ecelerity-modules-4.2.25.57347-1.x86_64 (symrepo_64_msys)
               msys-ecelerity-modules = 4.2.25.57347-1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
1
Script done, file is /data/logs/update.log
2017-12-28 06:35:25 +0000 sms-appliance-release-10.6.3-2 was not downloaded.
/opt/Symantec/Brightmail/software-update/sbin/functions.sh: line 268: [: too many arguments

Cause

The update is unable to resolve a software dependency for a required software package due to a higher version of the package existing in the software update repository.

Resolution