Plugins are not automatically downloaded to the target machine

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Article ID: 170677

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

There is a necessity to delivery a software, or to install an ITMS plugin, but it is never installed.

The Policy is delivered to the target machine, the process to install/validate the package starts, but it hangs when the policy is trying to download the package.

Analyzing the issue a little further, we can see in the policy that the package never received a "source link" from where the package should be downloaded.

<event date='11/17/2017 12:25:39.8210000 -02:00' severity='8' hostName='XXXXXXXXX' source='SWDAgent' module='smfagent.dll' process='AeXNSAgent.exe' pid='4428' thread='6704' tickCount='77281898' >
  <![CDATA[SWDAgent::DownloadNewPackages - Evaluating package Monitor Plug-in for Windows x64 (Monitor Plug-in for Windows x64)]]>
</event>
<event date='11/17/2017 12:25:39.8210000 -02:00' severity='8' hostName='XXXXXXXXX' source='SWDAgent' module='smfagent.dll' process='AeXNSAgent.exe' pid='4428' thread='6704' tickCount='77281898' >
  <![CDATA[SWDAgent::DownloadNewPackages - Package Monitor Plug-in for Windows x64 ({2E621CEB-9216-4E68-BE7E-1F84600D2073}) is not active]]>
</event>

Cause

Known issue, solved on ITMS 8.0 HF1

Environment

ITMS 7.6 x

Resolution

There are two options:

  1. Upgrade to ITMS 8.0 HF1 version, or any version after that.
  2. Validate the "Targeted Agent Setting". The configuration should be set to "Download the package file as soon as possible"

 

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