When creating a schedule using UTC, the agent scheduling engine is misinterpreting the UTC time.

book

Article ID: 170656

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

It appears that the agent scheduling engine is misinterpreting the UTC time.
When scheduling policy to run at 2 UTC for example, the agent schedules it to run at 5 AM.
The console also doesn't save the time that is input, auto-adjusts the time.

Cause

This issue started to happen with ITMS 8.1 RU3 and RU4. No present on 8.1 GA release.

The issue was caused by an unexpected changes done for the assemblies:
1. ComponentArt.Web.UI
2. Altiris.WebControls

Environment

ITMS 8.1 RU3 and RU4

Resolution

This issue has been reported to the Symantec Development team. A fix will be added under ITMS 8.1 RU5 (ETA: middle of January 2018)

A pointfix is available for ITMS 8.1 RU3 customers. See attached "Pointfix_eTrack4145518_8.1_RU3_SMP.zip"

 

REQUIREMENT:

ITMS 8.1 RU3 installed

 

HOW TO INSTALL THIS POINTFIX:

  1. Retrieve files from the archive to the NS hard drive.
  2. Run as administrator PFinstaller2.exe, click on ‘Install’ button
  • Note! PF contains only server-side fixes and do not require upgrade of clients or Site Servers.
  • Note! PF fixes scheduling for newly created or edited policies, for existing policies scheduled after 8.1 RU3 update it is recommended to perform visual sanity check through UI and correct scheduling if necessary.

 

CHANGES MADE:

Fixed issue with Console machine time zone settings impacting defined schedule for a policy if Console and SMP server reside in different time zones

 

QA PERFORMED:

  • Install/uninstall of PF above ITMS 8.1 RU3
  • Defining new schedules for Time zone and Culture (date/time format) difference for server and console machines
  • Defining new schedules for Localized OS with culture and time zone differences
  • Different types of policies scheduled (managed software delivery, MW policy, Agent rollout)
  • Scheduling a policy using shared schedules

 

 
This hotfix has the following known issues:

No known issues documented

 

HOW TO UNINSTALL:

  1. During PF installation – Backup folder created -where installer will copy all original files. (BackUp folder will be located in PF root)
  2. Execute PFInstaller2.exe with administrative privileges (right-click > Run as administrator).
  3. Accept UAC (User Account Control) prompt, select Uninstall.

Attachments

Pointfix_eTrack4145518_8.1_RU3_SMP.zip get_app