CLI command 'delete alllogs' hangs on dedicated Control Center

book

Article ID: 170554

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

The 'delete alllogs' command from the Messaging Gateway (SMG) command line interface (CLI) does not complete and appears to stop processing after deleting the agent_log file. Cancelling the command with control-C results in an error indicating that the mta process cannot be started

Example

smg-cc> delete alllogs
WARNING: Using ctrl-c to interrupt this program may corrupt your settings.
WARNING: You are about to delete the following:

        * dds logs
        * scanner logs
        * operating system logs
        * control center logs
        * synchronization service logs

Delete? (You must type 'yes' to confirm): yes
Removed file /data/logs/dds/dds.log
Removed file /data/logs/maillog
Removed file /data/logs/scanner/agent_log
^CUnable to restart mta:
Err
smg-cc>

Cause

The 'delete alllogs' command is attempting to delete objects that do not exist in the Control Center only installation and does not properly return from the failure.

Environment

Messaging Gateway

Resolution

This issue has been addressed with the SMG 10.6.4 release.