Failure when attempting to connect to Endpoint Manager database.

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Article ID: 170503

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Updated On:

Products

Endpoint Protection Advanced Threat Protection Platform

Issue/Introduction

When trying to connect to the Symantec Endpoint Protection Manager (SEPM) database within Advanced Threat Protection (ATP), you receive a connection Error.

ATP User Interface (UI) will show "connection error" under the Settings -> Global Settings -> Synapse.

Windows Application log will show:

Event ID: 17835 Logon

Encryption is required to connect to this server but the client library does not support encryption; the connection has been closed. Please upgrade your client library. [CLIENT: <ATP IP>]

Cause

This issue may be due to encryption being enable on the Microsoft SQL database in which the SEPM connects. At this time, ATP does not have a UI checkbox option to accept encrypted communication between ATP and SEPM SQL database server.

Resolution

{SUBSCRIBE.EN_US}

As a work around, you may append ;ssl=request to the name of the SEPM database. By default, this name is sem5. As an example, the entry should look as follows:

  • sem5;ssl=request

Alternatively, the Force Encryption option within Microsoft SQL server may be disabled.