Endpoint Protection Manager upgrade to 14 RU1 fails while Upgrading Database Schema

book

Article ID: 170496

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

When upgrading the Symantec Endpoint Protection Manager (SEPM) to 14 RU1 it says "Error occurred" when Upgrading Database Schema.

The following error is seen in <SEPM Folder>\tomcat\logs\Upgrade-0.log: (Note that the number listed may be different)

java.sql.SQLException: [Sybase][JDBC Driver][SQL Anywhere]Value 4294967040 out of range for destination

 

Cause

Fragmentation in the embedded database can cause the migration to fail.

Resolution

To resolve this issue, perform the following after experiencing the error and closing out of the failed migration.  Do not revert the installation, or the steps will not successfully resolve the issue. The paths given are the default SEPM installation locations.  If the install was done to a different location then the paths will differ accordingly.

1. Backup the database. (This should have already been done before starting the migration and may not work while in the broken state)
2. Ensure the SEPM services are stopped, including the Symantec Embedded
Database service.
3. Copy the attached ShrinkEmbeddedDB.bat to the SEPMs Tools folder, by default located in 
      C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Tools
4. Run the ShrinkEmbeddedDB in a command prompt.
5. Run the Management Server Configuration Wizard to retry the schema migration by running the "upgrade.bat", by default located in
      C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\bin

Attachments

ShrinkEmbeddedDB.bat get_app