DLP Endpoint agents do not appear in console or Agent events do not register on server

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Article ID: 170460

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Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

Scenario 1:

After installation of a new DLP agent, it does not show in the console. However, a review of the aggregate logs that were produced with the finest level log output confirms communication with the Endpoint Server.

Scenario 2:

Agents do not send an "Up" status to the console. Troubleshooting tasks run but they may not report as successful in the console.

Cause

This problem is due to a process deadlock with the Monitor Controller on the Enforce Server.

Environment

DLP 14.6

Resolution

Workaround:

Restart the Monitor Controller on the Enforce Server.

Restarting the Monitor Controller can be done in the Windows service console or the Enforce console.

  1. Browse to System > Servers > Overview, then select the Enforce Server
  2. On the server page click the recycle button next to the Monitor Controller Status.

 

This issue has been fixed in 14.6 MP3 and later.