Spam quarantine does not accept some messages

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Article ID: 170284

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Some messages with the Action "Hold in Spam Quarantine" instead accumulate in the Messaging Gateway (SMG) delivery queue and never appear in the Spam Quarantine.

Mar 18 2013 19:44:55 [SmtpWorker-12] ERROR - Cannot create a spam message in the database. 
com.symantec.smg.controlcenter.internal.dataaccess.DataAccessException: An
unexpected database error has occurred. Please contact your system
administrator. ; nested exception is: 
	 com.mysql.jdbc.exceptions.MySQLIntegrityConstraintViolationException: Column
'from_addr_email' cannot be null

Cause

Messages with a malformed "From:" header which do not contain a properly formatted email address are not accepted by the SMG Spam Quarantine. These messages are held in the delivery queue until they are eventually bounced.

Environment

Messaging Gateway

Resolution

This is a known issue with SMG 10.6.3 and earlier.

These messages cannot be accepted by the Spam Quarantine but can be routed to another mail server via the command line 'mta-control' command. Please see Rerouting messages in the delivery queue for more information.

This issue has been addressed with the SMG 10.6.4 release.