How do I troubleshoot web browser connectivity or errors? HTTP Fiddler / HTTP Header

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Article ID: 170270

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Updated On:

Products

Web Security Service - WSS

Issue/Introduction

How do I troubleshoot web browser connectivity or errors using  HTTP Fiddler / HTTP Header

  • Client and/or TSE needs to gather HTTP(s) traffic between a computer and the internet.

  • Gather data for troubleshooting and/or escalating connectivity in web browsers.

 

 

 

 

Cause

Supported Technologies


Any Browser

Telerik Fiddler web debugging proxy helps you record, inspect and debug traffic from any browser.



Any System


Debug web traffic from any Windows-based PC, Mac or Linux system and mobile devices alike.
 

Web Debugging

Debug traffic from PC, Mac or Linux systems and mobile devices. Ensure the proper cookies, headers and cache directives are transferred between the client and server. Supports any framework, including .NET, Java, Ruby, etc.



HTTP/HTTPS Traffic Recording

Fiddler is a free web debugging proxy which logs all HTTP(s) traffic between your computer and the Internet. Use it to debug traffic from virtually any application that supports a proxy like IE, Chrome, Safari, Firefox, Opera and more.

 

 

 

Environment

Web pages are failing to connect, getting errors, or intermittent disruptions.  

 




 

Resolution

Capture Web Traffic

 http://docs.telerik.com/fiddler/Observe-Traffic/Tasks/SearchSessions 

 

Open preferred web browser.
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In Fiddler, click the File menu.                                                

Ensure Capture Traffic is enabled.
 

Capture Traffic
 

Reproduce the issue, on the machine, and then start the Fiddler trace.

Once completed collect the client trace log and save the Fiddler trace and exit

Captured web traffic sessions appear in the Sessions List.

 

 

Sessions List

 

Once completed save the Fiddler trace log.
 

To save, select File> Save As> All Sessions
 



 

Upload your log to your case.
 



 

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