ITMS 8.1 RU2: 'Create new' database process in Symantec Installation Manager fails with "Failed to import ... CredentialManager.config" error.

book

Article ID: 170228

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

The Symantec Installation Manager (SIM) is an application that lets you install, upgrade, and configure the Symantec products, such as the IT Management Suite (ITMS). It is possible to perform the initial configuration of Notification Server and the database using SIM.

The process to 'Create new' database in ITMS 8.1 will fail with the error
=====
Failed to import the item from the file: C:\Program Files\Altiris\CredentialManager\Config\CredentialManager.config
=====

Steps to reproduce:
1. Install ITMS 8.1 RU2;
2. Run Symantec Installation Manager and browse to 'Configure settings' -> 'Configure Database Settings' -> 'Next';
3. Select 'Create new' under 'Database selection' ->  Give it a name -> (other database settings should be configured correctly ) 'Next';
4. The configuration process will fail at approximately 76%.


 

Failed to import the item from the file: C:\Program 
Files\Altiris\CredentialManager\Config\CredentialManager.config

Unable to locate the ItemClass associated with the specified GUID in the 
database nor in the XML: 51229704-0c30-46ff-aeab-c0b583b1d825
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS]
   at Altiris.NS.ItemManagement.Item.SearchClassInfo(XmlNode itemNode, Guid 
itemClassGuid, String strClassAssembly, String& strClassType)
   at Altiris.NS.ItemManagement.Item.ImportItem(XmlNode itemNode, Boolean 
needResult, ImportResult& result)
   at Altiris.NS.ItemManagement.Item.ImportItemFromDocument(XmlDocument doc, 
String filePath)
   at 
Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal(
String configFile, Boolean ownsProgressContext, SerializationMode 
serializationMode)

Exception logged from: 
   at 
Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal(
String, Boolean, Altiris.NS.Serialization.SerializationMode)
   at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProduct()
   at 
System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionCont
ext, System.Threading.ContextCallback, Object, Boolean)
   at 
System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, 
System.Threading.ContextCallback, Object, Boolean)
   at 
System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, 
System.Threading.ContextCallback, Object)
   at System.Threading.ThreadHelper.ThreadStart()

Cause

New defect. There is a conflict between General Availability (8.1 installation without Release Updates) and Release Update versions of CredentialManager.config file. 

Environment

ITMS 8.1 RU2.

Resolution

ITMS 8.1 RU2 users.
1. Extract the attached file PF_4126546.zip;
2. Run 'PFInstaller2.exe' as Administrator. 

There is an option to uninstall the point-fix if needed. 

ITMS 8.1 RU1 users.
Contact Symantec Support if a point-fix for your version is needed or upgrade to RU2.

ITMS 8.1 RU3 users.
Contact Symantec Support for a point-fix. 

 

Attachments

PF_4126546.zip get_app