After installing 7.5.6, items released from quarantine by email no longer arrive in the intended recipient mailbox

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Article ID: 170099

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

After upgrading to or installing Symantec Mail Security for Microsoft Exchange (SMSMSE) 7.5.6, items released from quarantine by email no longer arrive in the intended recipient mailbox, and reappear in the quarantine view. The Quarantine ID number is unchanged on the original item.

If a debug log is captured while reproducing the issue per How to Obtain Debug Logs for Symantec Mail Security for Microsoft Exchange (SMSMSE) a sequence similar to the following is observed:

[15964] SAVFMSETask(3E5C)[46C4] 2017-09-06 14:31:25 0035ms:
[15964] ..\..\..\src\Server\SAVFMSESHARED\MailStoreClient.cpp(209) :
[15964]  ===>Inside MailStoreClient::SendEmail()
[15964] 
[15964] SAVFMSETask(3E5C)[46C4] 2017-09-06 14:31:25 0040ms:
[15964] ..\..\..\src\Server\SAVFMSESHARED\MailStoreClient.cpp(217) :
[15964]  ===>Creation of Notification interface failed 0x80040154
[15964] 
[15964] SAVFMSETask(3E5C)[46C4] 2017-09-06 14:31:25 0040ms:
[15964] ..\..\..\src\Server\SAVFMSESHARED\MailStoreClient.cpp(218) :
[15964]  Debug Trace:  HRESULT=0x80040154 - Class not registered
[15964] 
[15964] SAVFMSETask(3E5C)[46C4] 2017-09-06 14:31:25 0040ms:
[15964] ..\..\..\src\Server\SAVFMSESHARED\NtfyMsg.cpp(133) :
[15964]  Debug Trace:  HRESULT=0x80040154 - Class not registered
[15964] 
[15964] SAVFMSETask(3E5C)[46C4] 2017-09-06 14:31:25 0041ms:
[15964] ..\..\..\src\Server\SAVFMSESHARED\TEncryptedItem.cpp(1247) :
[15964]  Debug Trace:  HRESULT=0x80040154 - Class not registered

 

Cause

SMSMSE 7.5.6 and later use an EWS based SMTP client. If the EWS binary is not registered, SMSMSE 7.5.6 will not be able to create SMTP sessions to send notifications or release quarantined items via email.

Environment

In the path <Installdrive>:\Program Files (x86)\Symantec\SMSMSE\<version>\Server\, there is no file called "Symantec.MailSecurity.EWS.Client.tlb".

Resolution

You must register the Symantec.MailSecurity.EWS.Client.dll.

 

To register the Symantec.MailSecurity.EWS.Client.dll:

  1. Navigate to C:WindowsSystem32, right click cmd.exe, and select Run as administrator 
  2. Run the command cd C:\Windows\Microsoft.NET\Framework64\v2.0.50727 
  3. Register the EWS assembly with the 64 bit version of .Net by typing:
    Regasm.exe /tlb "<Installdrive>:\Program Files (x86)\Symantec\SMSMSE\<version>\Server\Symantec.MailSecurity.EWS.Client.dll" "<Installdrive>:\Program Files (x86)\Symantec\SMSMSE\<version>\Server\Symantec.MailSecurity.EWS.Client.tlb" 

    then press Enter.

    NOTE: Change the value of <Installdrive> & <version> to the appropriate drive and version of SMSMSE installed. The following is an example for SMSMSE 7.5 on 64-bit OS:

    Regasm.exe /tlb "C:\Program Files (x86)\Symantec\SMSMSE\7.5\Server\Symantec.MailSecurity.EWS.Client.dll" "C:Program Files (x86)\Symantec\SMSMSE\7.5\Server\Symantec.MailSecurity.EWS.Client.tlb"​​

  4. Run the command cd C:\Windows\Microsoft.NET\Framework\v2.0.50727.
  5. Register the EWS assembly with the 32 bit version of .Net by typing:

    Regasm.exe /tlb "<Installdrive>:\Program Files (x86)\Symantec\SMSMSE\<version>\Server\Symantec.MailSecurity.EWS.Client.dll" "<Installdrive>\:Program Files (x86)\Symantec\SMSMSE\<version>\Server\Symantec.MailSecurity.EWS.Client.tlb"

     
    then press Enter.

    NOTE: Change the value of <Installdrive> & <version> to the appropriate drive and version of SMSMSE installed. The following is an example for SMSMSE 7.5 on 64-bit OS:

    Regasm.exe /tlb "C:\Program Files (x86)\Symantec\SMSMSE\7.5\Server\Symantec.MailSecurity.EWS.Client.dll" "C:\Program Files (x86)\Symantec\SMSMSE\7.5\Server\Symantec.MailSecurity.EWS.Client.tlb"​​