altiris_taskmanagement_8_1_x64.msi Failed with result InstallFailure during an upgrade to ITMS 8.1

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Article ID: 170006

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

During an upgrade to ITMS 8.1, SIM (Symantec Installation Manager) failed during the configuration process. The NS logs showed that altiris_taskmanagement_8_1_x64.msi failed during the installation process.

SIM Log entries:

Error 1:

RunMsiInstallProduct for package D:\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_taskmanagement_8_1_x64.msi Failed with result InstallFailure
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Date: 8/16/2017 2:01:45 PM, Tick Count: 616485875 (7.03:14:45.8750000), Size: 446 B
Process: SymantecInstallationManager (39092), Thread ID: 19, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Msi.ProcessMSIResult
 

Error 2:

Install failure while installing (ProductComponent: (Package) Task Management 8.1 x64 8.1.4511 InstallOption: InstallRequired) (in product Symantec Management Platform 8.1). Windows Installer API return code: 1603
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Date: 8/16/2017 2:01:45 PM, Tick Count: 616485875 (7.03:14:45.8750000), Size: 509 B
Process: SymantecInstallationManager (39092), Thread ID: 19, Module: SymantecInstallationManager.exe
 

MSI Install Log Entry:

MSI (s) (10:F4) [10:56:47:674]: Product: Task Management 8.0 -- Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action UninstallCTDataLoad.689FB43D_B797_4DE9_9A9F_86885A4025A5, location: D:\Altiris\TaskManagement\, command: "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\InstallUtil.exe" /u CTDataLoad.exe /LogToConsole=true /LogFile="CTDataLoad.InstallUtilLog
 

Cause

Known issue. Problem was because Task Management MSI execution failed, because of a Task Server services installation failure.
Impact statement:
Fixed sequence of custom actions which are used for TS services installation, to eliminate rollback execution after service installation.

Environment

Upgrade from 7.6 HF7 or 8.0 HF6 to ITMS 8.1

Resolution

This issue has been addressed under ITMS 8.1 RU3 release.