MicrosoftEdge.exe closes unexpectedly with Endpoint Protection Application Control enabled

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Article ID: 169847

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When you launch MicrosoftEdge.exe it closes unexpectedly after 10 to 20 seconds when it tries to open the first tab.

Windows Application log EventID 1000 error similar to the following:
Faulting application name: MicrosoftEdge.exe, version: 11.0.15063.332, time stamp: 0x591fdaf0
Faulting module name: EMODEL.dll, version: 11.0.15063.413, time stamp: 0x97b4ec41
Exception code: 0xc0000409
Fault offset: 0x00000000000eae6c
Faulting process id: 0x242c
Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe
Faulting module path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\EMODEL.dll

Cause

Application Control prevents an additional process MicrosoftEdgeCP.exe (Microsoft Edge Content Process) from running.

MicrosoftEdge.exe depends on MicrosoftEdgeCP.exe.

Since MicrosoftEdgeCP.exe fails to start, MicrosoftEdge.exe closes and logs the above error.

Environment

Symantec Endpoint Protection (SEP) 14 MP2 with Application Control
Windows 10 Creators Update 1703 Build 15063

Resolution

Create an Application Control Exception for MicrosoftEdgeCP.exe

  1. On the Exceptions Policy page, click Exceptions.
  2. Under Exceptions, click Add > Windows Exceptions > File.
  3. In the Prefix variable drop-down box Select [NONE].
  4. In the File text box, enter the following: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdgeCP.exe
  5. Under Specify the types of scans that will exclude this file, select Application control.
  6. Click OK.
  7. On the Exceptions Policy page, right click this policy, select Assign.
  8. Select the relevant Client Group.
  9. Click Assign.
  10. Click Yes.