Unable to load the Enhanced Console Views (Activity Center)

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Article ID: 169781

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

Unable to open the Activity Center (silverlight interface) using the Manage/ComputersManage/Software CatalogManage/Software, Manage/Jobs and Tasks or Manage/Policies.

No error message is received. The "old UI" (a basic layout) is loaded instead of the proper Enhanced Console View.

Cause

Since the Silverlight pages are installed after the platform, any update or repair of the platform could overwrite these pages. For example, after running aexconfig /configure for a software management config, customer is unable to load Enhanced Console Views using SMP Console.

Resolution

The first thing to try in this situation is to add the Silverlight specific file extensions in IIS under Request Filtering.  There are three file extensions which you can try adding.  They are:  xap, .xaml, and .xbap.  To accomplish this, open IIS Manager and navigate to Default Website.  On the right hand side of the screen double click Request Filtering.  Click on allow file name extension.  Type in each individual extension one at a time repeating for each extension.  You do not have to type the period as IIS will add that automatically for you.  Once complete, run an IISRESET and attempt to access the console.  If these steps do not work, continue reading for further action you can take.

If the related problem impacts only the Manage -> Software section, you could review the Menu configuration and make sure settings match with the following picture, especially: Show single page view and the URL: /Altiris/ActivityCenter/Default.aspx?viewGuid=0b9ae490-217c-48df-8f7f-2cda1cdd2a00

1) In the Symantec Management ConsoleGo to Settings/All Settings/Notification Server/Console Settings/Menus;

2) Select Manage/Software;

 

If the problem remains or the same problem is also occurring to Manage/Computers, or to Manage/Software Catalog, or Manage/Jobs and Tasks or Manage/Policies:

1) Navigate to \Program files\Altiris\Symantec Installation Manager\Installs\Altiris;

2) Find the altiris_activitycenter_X_X_X_x64.msi file for the current version of Altiris. Right click and choose Uninstall. 

3) Once that is complete, Open a command prompt and enter msiexec /i then drag and drop this same MSI into a command prompt window. Press the spacebar once and then add "skipaim=1". Hit enter and the MSI should reinstall. 

4) Wait for a minute or two, once the MSI completes, for the database to finish updating.

5) Next open up an administrative command prompt and run 'iisreset' [ I have found that if you do not reset iis after repairing the activity center, the pages will try to load but then error out. The page will start to load but then stop and show an error in the bottom left hand corner of Internet Explorer ]

If you modified any settings under Settings->Console->Enhanced Views, they will need to be reset.

 

Applies To

 

ITMS 7.1, 7.5, 7.6, 8.0, 8.1