Error "An IO Exception has occurred while accessing file" during download MSI file process within SIM

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Article ID: 169778

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

While trying to install ITMS 8.1 in a new server, the following error appeared in the SIM install logs during the MSI download file process:

An IO Exception has occurred while accessing file.
Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

When trying to access the file using the download link directly from the IE browser, for example:
'http://www.solutionsam.com/solutions/8_1/altiris_console_8_1_x64.msi?symct=1499450826_485df3c25a9d39dfdb9ee14ddfb40900'

Internet Explorer failed to download the file and displayed this message:

"This program couldn't be downloaded"

Entry 1:
DownloadFile - Downloading file from 'http://www.solutionsam.com/solutions/8_1/altiris_console_8_1_x64.msi?symct=1499450826_485df3c25a9d39dfdb9ee14ddfb40900' to 'file:///C:/PROGRA~1/Altiris/Symantec Installation Manager/Installs/Altiris/altiris_console_8_1_x64.msi'
-----------------------------------------------------------------------------------------------------
Date: 7/7/2017 9:07:06 AM, Tick Count: 251671 (00:04:11.6710000), Size: 549 B
Process: SymantecInstallationManager (4176), Thread ID: 15, Module: SymantecInstallationManager.exe
Priority: 4, Source: Symantec.Installation.FileDownloader.DownloadFile

 

Entry 2:
An IO Exception has occurred while accessing file.

Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
   [System.IO.IOException @ System]
   at System.Net.ConnectStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at Symantec.Installation.FileDownloader.WriteFile(Stream source, Stream destination)
   at Symantec.Installation.FileDownloader.<>c__DisplayClass25.<>c__DisplayClass2b.<DownloadFile>b__23(WebResponse webResponse)
   at Symantec.Installation.FileDownloader.OpenHttpStream(Uri fileUri, Func`2 func, Action`1 initRequest)
   at Symantec.Installation.FileDownloader.<>c__DisplayClass25.<DownloadFile>b__22()
   at Symantec.Installation.FileDownloader.FileOperation(Func`1 action)

An existing connection was forcibly closed by the remote host
   [System.Net.Sockets.SocketException @ System]
   at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.FileDownloader.FileOperation(Func`1 action)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri sourceUri, Uri destinationUri, Int64 fileSize)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri source, Func`2 downloader)
   at Symantec.Installation.FileDownloader.<DownloadFiles>b__18(DownloadFileInfo downloadFileInfo, ParallelLoopState state)

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Date: 7/7/2017 9:07:07 AM, Tick Count: 252062 (00:04:12.0620000), Size: 2.80 KB
Process: SymantecInstallationManager (4176), Thread ID: 15, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.FileDownloader.FileOperation

 

Entry 3:
Downloaded package 'http://www.solutionsam.com/solutions/8_1/altiris_console_8_1_x64.msi?symct=1499450826_485df3c25a9d39dfdb9ee14ddfb40900': Status: Failure
-----------------------------------------------------------------------------------------------------
Date: 7/7/2017 9:07:07 AM, Tick Count: 252078 (00:04:12.0780000), Size: 442 B
Process: SymantecInstallationManager (4176), Thread ID: 15, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Automation.Output.ReportError

Cause

Environmental. In this particular instance, the firewall was blocking some of the download traffic. 

Environment

New installation ITMS 8.1

Symantec Installation Manager 8.1.5037

Resolution

The issue was resolved by configuring the firewall to allow communication to the www.solutionsam.com site and traffic to the Akamai servers where the MSIs are hosted.

Other things that could help on similar behavior: 

  1. Verify that there is not a proxy blocking the download process.
  2. Verify that there is not an antivirus locking the destination drive.